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-Attention.

1: Installation - User ID registration

To use Frames, you will need to install software.

*Please refer to the details for the recommended environment (⇒ P28)

Operating Procedure

Run Misumi_Frames_setup_dl.exe

• If you are not up-to-date with Windows Update, 
• you may not be able to install the software correctly.
• Please do so while connected to the Internet.
• You will need to download the necessary files during 

installation.
• Do not execute any files other than the installer during 

installation. It may not be installed correctly.

*Administrative privileges may be required.

Proceed with the installation according to the screen.
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2: Screen configuration

Camera Control

Area used for camera operations 
such as viewpoint changes and 
movement.

Screen Fit

All drawing objects fit
Displayed to scale.

Pan

Switches the camera to 
move mode

Rotate

Switch the camera to 
rotate mode

zoom

Switch the camera to 
zoom mode

Configuration
Default Part, Mouse Operation, 
Shortcut Key, etc.

View Control
Change the viewpoint with 
selected surface.

Change view

Dimensioning/fastening 
parts in focus

The display will be shown.

Header menu

There are File, Tool, Help, Intermediate File Output,
Drawing Creation, and Parts List Output/Quotation 
menus.

Insert Menu

Select and insert a 
template or component 
from the list.
Model number search is 
also available.

Part Edit Tool

Used when editing a selected part.
It is displayed when a placed part is selected, and the display location 
can be moved to a right-clicked point.

Guide shape

Use for Display and 
Non-Display Guide data 
or Grid line

Parts Selection 
List

You can check and 
change the products
you have placed. You 
can also adjust the 
display size of the 
frame.
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- Hint -.

3: Mouse operation

In FRAMES, the design is displayed on the 3D 
screen.

Firstly, please check basic viewpoint operations 
on the 3D screen.

8 mouse operation patterns are available.
Please select according to your preference.

1 Frames Standard

2 SOLIDWORKS like

3 CATIA like

4 NX (NX9 or later) like

5 NX (NX10 or later) like

6 iCAD like

7 Creo (Pre Pro/E) like

8 Inventor like

Operating Procedure

Basic screen Move the viewpoint by dragging 
the mouse scroll wheel.

You can change the viewpoint 
during drawing anytime.

Rotate the camera by 
dragging the right 
mouse button.

Zoom in/out of the camera 
by using the mouse scroll 
wheel up and down.

e.g: Frames standard

Mouse operation settings can be changed.

[How to check/setup]
Click on "File" menu in the upper
left corner of the screen
→Select Configuration.
→Select Mouse Operation.
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4： Configuration

- Hint -.
Settings can be changed in Configuration menu.

You can change mouse operation to suit your CAD system 
or set the default settings for frequently used components.

The default settings for the most frequently used parts 
will make it easier to use.

Operating Procedure

You can open the settings screen
from the camera control area.

(1) Display Configuration (2) Change settings
Select “File” menu in the upper 
left corner of the screen
→ Configuration
→ Select each item

<Item Summary>

General
Set the area size, grid width, projection method and 
other settings related to the screen display at the time 
of drawing and set the tutorial to be displayed again.

Mouse operation
Set the mouse operation assignments for camera 
control operations.

Shortcut key
Set shortcut key assignments for operations such as 
saving files.

Default Part
Set the parts that are inserted by default and the 
fastening method for panels that are inserted 
automatically.

Release notes You can check release notes information.

About MiSUMi Frames
You can check notices of campaign information and 
maintenance information.

Help You can check links to various types of support.
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Basic operation
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- Hint -.

1: Aluminum Frame Insertion

Select Aluminum Frame and easily insert on 
the screen by selecting and clicking on start 
and end points.

Brackets and other fastening parts are also
automatic placement.

Operating Procedure

The placement of products is supported by 3 different color 
displays.

(1) Blue
Correctly fastened part

(2) Orange
Locations to be adsorbed in 
alignment

(3) Red
Error location

(1) Aluminum Frame Selection

Select Frame from 
"Aluminum Frame" in 
Insert menu.

(2) Placement

Click start and end points, 
then click place Aluminum Frame

You can specify length 
dimension of Aluminum 
Frame, by pressing "Tab" 
key on your keyboard 
and manually inputting 
desired length value.

(3) Completion

Click "Finish" button to
exit placement mode

Click starting point

Click again at the end point
For the fastening part
Brackets automatically 
placed!

[Basic operation]
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2: Fastening parts Insertion

- Hint -.

When mouse cursor close to Aluminum frame, it will be absorbed in the position 
where it can be inserted, so click at the position where you would like to place it.

*Brackets can only be placed where they are connected to 2 Aluminum frames.
Example: Bracket selection screen

Click on a placeable 
location to place it.

The length of Aluminum 
Frame is automatically 
shortened by the Corner 
Brackets placed.

Bracket/Corner Bracket/Blind Bracket/
Joint/Sheet Metal, etc. are available.

Nut can be inserted by itself.

(2) Placement

Operating Procedure

(1) Select Fastening parts

Inserted joints, etc. can be confirmed in the "Display fastening parts" 
in the camera control tool.

When clicked, the fastening parts are
Highlighted and Other parts are transparent

Select the product from Insert menu

For other parts can be 
placed by using mouse.

[Basic operation]

Example: Nut selection screen

Double fastening is 
possible by using 
reinforcement frame 
brackets.
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- Hint -.

3: Panel insertion

Once panel is in place, the additional machining on 
fastening parts and placement of necessary parts are 
also available.
This is done automatically and reflected in the BOM.

In placement mode, can click 
"Change insert product" button to 
change panel clearance or 
thickness or select bolts, nut, 
brackets, etc.

[Basic operation]

In FRAMES, 
Easy to insert Panel

Operating Procedure

You can change the fastening method from the change panel screen.

[Possible Fastening Methods]
- Bracket fastening
- Panel Clamp Fastening
- Aluminum Frame Fastening
- Door frame fastening
- Sliding door frame fastening

(1) Panel selection (2) Placement

Panels can also be inserted onto 
end surface of Aluminum Frame.

(Bolts are placed avoiding the 
end surfaces.)

Select Panel from Insert menu Click on surface to place Panel
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- Hint -.

4: Door creation function - easy setup

Select "Create new" from Door in Insert 
menu, then select surface which the door 
will be placed.

(2) Select the type of door

The door creation screen is launched.
First, select the door type.

Door 
creation 
screen

Please select the door opening direction

(3) Selection of essential parts
Select products such as Aluminum frames, Hinges, 
Handle, Frame Cap. The selected products will be 
placed automatically.

Check the automatically created door 
and if there are no problems,
click "Insert". It will be placed as is in 
the 3D screen.

With FRAMES, you can quickly design door 
by simply selecting the minimum necessary parts.

No need to set Clearance.

You can select the type of door; One hand door, Double door, 
Folding door, Panel door, and Panel double door

Operating Procedure

(1)Select surface to insert the door

You can select how to insert door unit

Insert as an door assembly → you can edit on this function 
after insertion.
Inserted as an each parts → you cannot edit the door with this 

function again.

Please select according to your application

[Basic operation]

Panel door design
is also possible.

*If you would like to edit it further
See in Detailed Settings in (⇒ Advanced Operations, P.23)
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- Hint -.

5: Accessory parts insertion

Intuitive product placement is possible according to various 
placement methods.

Example: Frame cap selection screen

Example: Handle selection screen

Triangular pyramid mark 
will be shown on 
possible placement 
locations.
Click on Triangular 
pyramid mark to place 
Frame cap.

Or click again to remove 
Frame cap.

Click to place Handle 
where available for 
placement.

[Basic operation]

Various accessory parts for design such as 

Frame cap/Slot cover/Handle/Hinge/Magnetic catches, 
etc. are available.

It can be selected and arranged from the screen 
same as Aluminum Frame placement.

(2) Placement

Operating Procedure

(1) Accessory Parts Selection

Frame caps can be installed by 
recessing cap thickness.

[How to change]
When placing Frame caps, tick in 
a box ☑ Insert by depressing the cap 
portion. on the upper left of screen.

Click on "Accessory Parts" from Insert menu, 
then select a desired product.



© 2022 MISUMI Corporation, All Rights Reserved.
12

- Hint -.

6: Part editing (move/stretch/rotate/information view/copy/delete)

With FRAMES, the model number 
automatically follows as you edit the product.

No troublesome model number management 
or modification work is required.

Operating Procedure

Various shortcut keys are 
also available for set up.

[How to check/setup]
Click on "File" menu in the 
upper left corner of the screen

→ Select Configuration
→ Select Shortcut Key

(2) Select a function from 
Part Edit Tool menu.

Movement Expansion and Contraction Revolution

Product Information Details DeletionCopy and Place

After specifying the 
direction of movement
Move by mouse operation

After specifying the direction of 
expansion and contraction
Expansion and contraction by 
mouse operation
(Full length and differential can 
be selected)

After specifying the direction of rotation
Rotate by mouse operation

Selected Product Information
Screen activated

After specifying the placement direction
Placement by mouse operation

Delete selected parts

(1) Change the range of products by using mouse

[Basic operation]
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- Hint -.

7: Product change

(2) Select products

Example: If you would like to change the bracket

*Items that cannot be changed are 
displayed in red.

Bracket Selection Screen

Change Complete

[Basic operation]

Easy to change the placed products
whether single item or multiple items.

Operating Procedure

(1) Click on "Change Product

You can change multiple products 
at once If they are the same 
products.

After selecting a product, click on 
"Collective change" button on
the products list screen. 
Then, selecting the desired product, 
and click "Apply".

After selecting the product, 
click "Change Product" in the Part Edit Tool box.

Select the product you would like to change, and the product selection screen 
will appear. After selecting the desired product, click "Apply".
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- Hint -.

8: 2D drawing output

Assembly

Assembly DevelopmentFrame

PanelDimensions (Outline)

(2) Drawing creation

[Basic operation]

The design project is easily output to a 2D drawing.

You can select Dimensional drawings, Assembly drawings, 
Assembly development drawings, Panel drawings, or 

Frame drawings.

Operating Procedure

(1) Drawing selection

2D Drawing can be printed 
or exported in DXF file format.

[Output Method]
Click Export/Print on 
2D Drawing screen

For Drawing output, 
Click "Drawing" button from Header menu.
Then, select Drawing type that would like to output 

The specified drawing will be created. 
*It takes some time to create drawing for the first time.

Select 
Drawing type

Drawing pages can be added by clicking on      button on the right side of 
the screen.You can also switch pages by clicking on the numbers.

You can switch to other 
drawings type by clicking 
"Outline" from Header menu.
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- Hint -.

9: Drawing edit (explanation of each edit button)

After the Drawing is created, click on each edit function to edit the item.

Drawing Edit Screen
Bill of Materials Editing

Change display items

Figure Frame Editing

DXF import is also available Section view

View sectional 3D drawing 

Isometric view
Can change side view and scale

3 View Selection

Balloons, Dimensions and 
Annotations

You can edit by clicking button 
from Header menu.

Example: Edit dimensions

[Basic operation]

You can edit Drawing by moving, changing scale or
add Balloons, Dimensions, Annotations, etc.

Sectional views or Isometric Drawings can be also added.

Operating Procedure

When creating a 3-view plan, 
select the plane
and scale can be changed.

Follow the selections on the 
screen, then create and edit.

Specify the view to display
You can click "Change layout" button 
frombottom right corner of the screen 

for editing Drawing size.

Display surface selection

front selection

Scale Selection
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10: BOM check/edit and BOM output [Basic operation]

Display bill of materials for the design project.

Operating Procedure

View/Edit Bill of Materials

You can click "BOM, estimate" button from Header menu,
for viewing part list.
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11: Default part settings

In Frames, you can set Default Part from 
configuration and it can be automatically inserted.

Please modify to suit your design.

Default part change

Automatic Fastening part change

The following products can be set.
- Aluminum Frame
- Panel
- Frame Cap

You can set parts that will be automatically fastened 
when placing Aluminum Frame. 
Please set it for each frame size.

① Select Aluminum Frame Series, Number of Slots 
and angles that you would like to set.

② You can set fastening parts for each placement 
method, and it will be saved.

[Basic operation]

Operating Procedure

- Hint -.

You can set Default Part 
from Insert menu.

(2) Select "Default Part"(1) Select "Configuration" 
from “File” menu 
in the upper left corner.

(1)

(2)



© 2022 MISUMI Corporation, All Rights Reserved.
18

Advanced operation
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- Hint -.

-About the specifications

1: Intermediate file output

Click on "Intermediate File Output" in the 
Header menu

■Recommended CAD
- SolidWorks 2016/2017
- iCAD V7L5
- NX 11
- Inventor 2018

■Output Format
- STEP format (AP214)
- Parasolid format (V9.0)
*STEP format is recommended.

After selecting Output destination and 
File format, click "Export" button.
An intermediate file will be created.

If the conversion takes time,
An estimate creation time 
is displayed.
If there are is no problem, 
select OK.

2) Operation with CAD

[Advanced operation]

With Frames, the design project can be 
output in Intermediate file format.

■Recommended Environment
- Same as Frames operating environment
(Excerpts from main recommended environments)

- OS :Windows 10 64bit
Windows 11 64bit

(edition: Professional , Enterprise)
- Graphics board : Quadro (NVIDIA)

FRAMES is not guaranteed to be used in virtual 
environments such as Hyper-V and
VMWare. Please install the software on actual device.

Operating Procedure

(1) Export

Conversion and Merge tolerance 
of intermediate file can be adjusted.

*Default setting is recommended.

Please import the data into your CAD system
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- Hint -.

2: Template Core Equipment Insertion

3D Drawing screen

(1) Template insertion

(2) Core equipment data insertion

In "Template" in the Insert menu
Standard Units" or My Units.
Click to select the shape.

Enter dimensions for placement
With dimensions reflected.
The unit will be placed.

Click “Insert STL Data” from 
Header menu to import STL format 
data and shape format.

If imported core equipment 
overlap with other part, 
it will be displayed in red.

[Advanced operation]

In Frames
You can insert templates and core equipment models.

Templates allow you to create your own frequently used
by saving the shape as "My Units“.

Operating 
Procedure

It is also possible to create simple shapes 
without loading core equipment data.

After clicking "Insert Simple Shape" 
from header menu, input dimensions.

1 (
2
)

Save My Unit

Input Template name and 
select saved destination.

Select “Save as a template” button 
From File menu and click 
“Save destination settings”.

*For save destination, go to 
"Group to save to" field,
You can create a new one by 
directly input name.
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- Hint -.

3: Guide Shape Function - Function Description

In FRAMES, you can create a rectangle guide 
shape based on STL data such as equipment,
and place Aluminum Frame along the guide 
shape.

Use for designing equipment covers and other 
equipment.

- Image of design using guide shape-

Load core equipment Create guide shape Create Aluminum Frame accordingly

STL format file can be read.

You can check interference 
and create a guide in this function.

• Create a rectangle guide shape 
from core equipment 
• Can be created by setting 
clearance with core equipment

Places Aluminum frames along the created guide shape

Can be placed inside or outside

*Outside stick: Convenient when placing equipment inside
Inside stick: Convenient when equipment is installed outside

Outside stick Inside stick

Matching equipment
Size Structure is complete!

Completion image

Operating Procedure

Guide shape can be displayed/hided at anytime.

[How to display/hide]
Click "Guide shape" on the right side of screen
Display guide data:.
→ Click for Display or Hide

Display grid line
→ Click for Display or Hide

[Advanced operation]
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- Hint -.

4: Guide Shape Function - Operation Flow

Guide shape can be set not only from equipment data, 
but also possible to set numerical value.

Stick guide shape method and Grid can be also set.

Please use it according to your own design method.

(1) From “Tools" in Header menu
Click on "Insert guide shape

*For differences in stick position
see previous page

(2) Select Stick position

• Create with a rectangular guide shape 
by inputting size
• Load core equipment and 
create guide shape on equipment data

(3) Select the creation 
method

(4) Make various settings 
(please customize according to 
your own design method)

Configuration setting
• Size

→ can be expand or reduce size 
after placement
• Placement position

→ can be moved after placement
• With/without grid

→ can be selected with or without 
grid
• Stick position 

→ can be selected outside or 
inside stick position

-Example of customization

[Setting details]
• Size

→ Size of building with one person's 
space left empty.
• With/without grid

→ Without
• Stick position 

→ Inside stick

[Setting details]
• Size

→ Slightly wider and thinner than 
equipment
• With/without grid

→ Only the center line is displayed.
• Stick position 

→ Outside stick

Base plate instead!

As an indicator of 
equipment placement 
restrictions!

Operating Procedure

The created guide shape is saved in the project together with the designed structure.
It can be viewed as indicator at any time, unless deleted

[Save method]
Save the project as usual *It will be saved automatically.

[Advanced operation]
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- Hint -.

5: Door creation function - detailed settings

You can make detailed customization 
to the door you create.

*Even you are in Easy setting, 
you can click "Details" button for more 
detailed setting.

Various editing is possible, such as changing/adding/deleting parts, changing size/clearance, etc.

Frame size
Change frame 

type

Panel Change Accessories parts 
change

Clearance change

When settings are changed on the various 
screens, the changes are reflected.

Parts can be moved and deleted directly on the 3D screen.
If you want to change a part, please change it within the tab 
screen.

Operating Procedure

(1) Click on "Detailed" button on 
Door - Easy setting screen.

Save the door settings once created and the next time you create a door.
It is possible to call up.

[How to save]
On the confirmation screen before door insertion,

Select "Save this setting”

[Call up method]
When creating a door, select "Load the door file"

[Advanced operation]
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7: Suspension parts insertion

- Hint -.

Example: Plate selection screen

Plate/Caster/Foot Base/
Adjuster pads are available.

After selecting the product, insert it into 
Aluminum Frame.

Operating Procedure

Adjuster pads are designed to prevent the floor from
Height adjustment (0.5mm increments)

[How to change]
Select the adjuster pad and click "Change Product"
then, input value in "Adjustment pad Insertion position“
field.

(1) Select Suspension parts

Click "Suspension parts" button from Insert 
menu, then select a product

(2) Select combination parts

*When placing it on the bottom side, it will be easier to 
insert it if you look up from the bottom of the design.

Example.)
Insert from 
Caster list

(3) Placement on Aluminum frame

After select plate, "change suspension part" screen will be 
displayed. 
Click on part number of suspension parts to open the 
product selection screen.

Move the mouse cursor close to Aluminum frame, 
caster will stick to the placable position, so click 
on the position you would like to place it.

You can continue placing products until you click 
"Done" button.

*When placing it on the bottom side, it will be easier 
to insert it if you look up from the bottom of the 
design.

[Advanced operation]
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- Hint -.

Additional machining (alteration) can also be edited
on "Change Product" screen or Edit menu 
after selecting a product.

8: Manual add-on function - Flow of operation

Frames allows you to manually add alterations for 
Aluminum Frame and Bracket. 

Please use it for designing holes for mounting 
various parts.

Operating Procedure

(1) Select product for proceed alteration. (2) Select the alterations

Heli-coil insert can be selected 
by tick box "Insert insertion"

Fixed position Specified position and direction

*The direction and position of hole 
can be changed.

Multiple selection of parts is possible 
while press Shift key and select products.

Brackets require additional C-holes
can be inserted

(3) Specify the position and direction of processing

Check alteration settings and if there is 
no problems,
click "Finish" button on screen to 
complete the insertion.

When you select a product on the 3D screen,
List of alterations screen will be opened.
Click"Edit" button, and then click "Add" on the 
next screen.

Follow the displayed guide to specify alteration position, direction,
and type of machining.

A list of additional operations that can be added 
will be displayed.
Select the type you wish to add.

Click on "Alteration" button form Insert menu,
and then select part number to alteration.

(4) Reflect alteration processing

*Additional manual alteration setting will be highlighted in gray as shown in part number.

[Advanced operation]
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- Hint -.

9: Measurement and strength calculation functions

(2) Frame strength calculation

In Header menu,
Select "Measure frame strength" to 
activate strength calculation mode.

In Header menu,
Select "Measure" to activate 
the measurement mode.

Select the staring point 
or object (Frame/Part)

Select the ending point or 
object (Frame/Part)

Click "blue triangle" on the frame 
you would like to calculate

Concentrated load and Uniform load are 
displayed for checking

In Frames, 
Measure frame length and strength 
are available to check.

Operating Procedure

(1) Measuring function

You can check length of all Aluminum frames 
designed at once.

[How to check]
Select "Change view" from camera control 
on the right side of screen.
Then select "Display dimension" button

When measuring by selecting a surface,
the selected surface is indicated by ☒ .

(1)

(2)

[Advanced operation]
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10: Total mass calculation 

- Hint -.

2) Parts Selection (3) Confirmation of results

In Frames, 
Total mass of created design structure 
are available to check.

Operating Procedure

(1) Select Calculate Total mass

If you would like to select multiple parts
Hold down the Shift/Ctrl keys to select the part.
Click or drag the mouse to make a selection.

Click on part that you would like to 
check

Mass of selected part will be displayed on 
"Calculate the total mass" at the bottom left of 
screen
Click "Finish" button to exit measurement mode.

Click on another part, 
the total mass will be 
updated automatically.

[Advanced operation]

In Header menu,
Select "Calculate the total mass"
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Recommended Frames Environment [Appendix]

Recommended Specs

OS
Windows 10 64bit
Windows 11 64bit

CPU Core i5 (2.7GHz, 4-core) or higher

memory 8GB or more

HDD free space 
required

5GB～

graphics board NVIDIA recommended

Software Configuration

application body A set of execution modules for this system

database SQLite


